selfoss.DEBUG messages in Apache error.log

by cpunke, Friday, July 14, 2017, 12:52 (435 days ago)

I found many logs in /var/log/apache2/error.log like these:

[2017-07-14 07:00:02] selfoss.DEBUG: set cookie on localhost/selfoss/ expiring in 2592000 seconds [] []
[2017-07-14 07:00:02] selfoss.DEBUG: session does not contain valid auth [] []
[2017-07-14 07:00:02] selfoss.DEBUG: Establish database connection [] []
[2017-07-14 07:00:02] selfoss.DEBUG: --- [] []
[2017-07-14 07:00:02] selfoss.DEBUG: start fetching source "Der Postillon (id: 3) [] []
[2017-07-14 07:00:02] selfoss.DEBUG: spout successfully loaded: spouts\rss\feed [] []
[2017-07-14 07:00:02] selfoss.DEBUG: fetch content [] []
[2017-07-14 07:00:03] selfoss.DEBUG: minimum date: 2017-06-30 07:00:03 [] []
[2017-07-14 07:00:03] selfoss.DEBUG: start item fetching [] []
[2017-07-14 07:00:03] selfoss.DEBUG: destroy spout object [] []
[2017-07-14 07:00:03] selfoss.DEBUG: --- [] []

selfoss is running fine.

the logger_level in config.ini is set to NONE.

Somebody any ideas where to switch off these messages?

selfoss.DEBUG messages in Apache error.log

by jtojnar, Friday, July 14, 2017, 22:39 (435 days ago) @ cpunke

Setting logger_level=NONE turns the logging off for me. Curiously, you see the errors in /var/log/apache2/error.log but selfoss logs into $selfoss_dir/data/logs by default. Do you, by any chance, use a modified version of selfoss, for example, a version provided by your package manager?

selfoss.DEBUG messages in Apache error.log

by cpunke, Saturday, July 15, 2017, 11:01 (434 days ago) @ jtojnar

First I use the version provided via download from selfoss.aditu.de, Version 2.17.
Installed/updated regarding to the docs on the selfoss website.

Running on debian 8 with apache 2.4.10

And in $selfoss_dir/data/logs there are no logs too, as expected because of logger_level=NONE.


I don't have any idea where teses debug logs come from...

selfoss.DEBUG messages in Apache error.log

by cpunke, Saturday, July 15, 2017, 18:29 (434 days ago) @ cpunke

If I set logger_level=ERROR in config.ini the messages in apache-error.log no longer appear.

Set logger_level=NONE the selfoss.DEBUG-logs are back...

Weired?

selfoss.DEBUG messages in Apache error.log

by jtojnar, Saturday, July 15, 2017, 21:34 (434 days ago) @ cpunke

Could you open an issue in the tracker? Maybe someone else will be able to help there.

https://github.com/SSilence/selfoss/issues

selfoss.DEBUG messages in Apache error.log

by cpunke, Wednesday, July 19, 2017, 12:08 (430 days ago) @ jtojnar

I opened an issue on github...

RSS Feed of thread
powered by my little forum