Installation problems - Ubuntu 16.10

by andy47, Tuesday, January 10, 2017, 00:52 (553 days ago)

I'm trying to install selfoss on a freshly installed Ubuntu 16.10 virtual machine. I have installed the PHP application files under the apache www root and installed and enabled all of the necessary Apache, PHP and SQLite libraries in Ubuntu.

However when I go to the application main URL I see this message presented:

Internal Server Error

Fatal error: PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/php_pdo_sqlite.dll' - /usr/lib/php/20151012/php_pdo_sqlite.dll: cannot open shared object file: No such file or directory

I can confirm that there is no dll of that name in that directory on my machine. But when I check phpinfo SQLite support is definitely enabled. From a call to phpinfo():

PDO

PDO support enabled
PDO drivers sqlite
pdo_sqlite

PDO Driver for SQLite 3.x enabled
SQLite Library 3.11.0

Can anyone point me at what might be causing this problem? My only current thought is that Ubuntu 16.10 by default only supports PHP 7. Is this a problem for selfoss?

Installation problems - Ubuntu 16.10

by jtojnar, Tuesday, January 10, 2017, 08:36 (553 days ago) @ andy47

It seems like you are attempting to use Windows version of the SQLite library.

If you use libapache2-mod-php7.0, the configuration file should be in /etc/php/7.0/apache2/php.ini. There you should look up php_pdo_sqlite.dll and comment it by adding semicolon at the beginning of the line. SQLite should actually be loaded by /etc/php/7.0/apache2/20-pdo_sqlite.ini, please check that it contains line extension=pdo_sqlite.so. Lastly, the Apache instance should be restarted using sudo systemctl restart apache2.

RSS Feed of thread
powered by my little forum