Trouble with lighttpd 1.4.40

by R00KIE, Tuesday, July 19, 2016, 01:57 (854 days ago)

Lighttpd was just updated to version 1.4.40 in Arch Linux ARM and selfoss does not work with it.

I have traced the problem to the rewrite rules. I've been trying to get selfoss to work properly by tweaking the rewrite rules but I haven't been able to get it to work 100% correctly.

Any experts in lighttpd here that could provide some help or pointers?

Rules that work with lighttpd 1.4.39:
server.port = 9090
server.document-root = "/usr/share/webapps/selfoss"
server.errorlog = "/var/log/lighttpd/error.log"
dir-listing.activate = "disable"
index-file.names = ( "index.php" )
server.modules += ( "mod_rewrite", "mod_cgi" )
cgi.assign = ( ".php" => "/usr/bin/php-cgi" )
url.rewrite-once = (
"^/public/.*$" => "$0",
"^/favicon.ico$" => "/public/favicon.ico",
"^/favicons/(.*)$" => "/data/favicons/$1",
"^/thumbnails/(.*)$" => "/data/thumbnails/$1",
"^/(.*.(js|ico|gif|jpg|png|css|asc|txt|eot|woff|ttf|svg))$" => "/public/$1",
"^/index.php(.*)$" => "$0",
"^/([^\?]*)(\?(.*))?" => "/index.php?$3",
"^/(.*)" => "/index.php$1"
)
include "/usr/share/doc/lighttpd/config/conf.d/mime.conf"

Rules that do something with lighttpd 1.4.40 but some things are broken:
server.port = 9090
server.document-root = "/usr/share/webapps/selfoss"
server.errorlog = "/var/log/lighttpd/error.log"
dir-listing.activate = "disable"
index-file.names = ( "index.php" )
server.modules += ( "mod_rewrite", "mod_cgi" )
cgi.assign = ( ".php" => "/usr/bin/php-cgi" )
url.rewrite-once = (
"^/public/.*$" => "",
"^/favicon.ico$" => "/public/favicon.ico",
"^/favicons/(.*)$" => "/data/favicons/$1",
"^/thumbnails/(.*)$" => "/data/thumbnails/$1",
"^/(.*.(js|ico|gif|jpg|png|css|asc|txt|eot|woff|ttf|svg))$" => "/public/$1"
# "^/(.*)$" => "",
# "^/([^\?]*)(\?(.*))?" => "/?$3",
# "^/(.*)" => "/?$1"
)
include "/usr/share/doc/lighttpd/config/conf.d/mime.conf"

Trouble with lighttpd 1.4.40

by R00KIE, Saturday, July 23, 2016, 16:39 (849 days ago) @ R00KIE

It seems this was due to a change in lighttpd, see http://redmine.lighttpd.net/issues/2738

This change will be reverted in lighttpd 1.4.41. Meanwhile either use lighttpd 1.4.39 or you can use the workaround described here http://redmine.lighttpd.net/boards/2/topics/6758?r=6763#message-6763

RSS Feed of thread
powered by my little forum