Feed loading error; exception thrown for XML/PCRE extensions

by cactus, Monday, April 25, 2022, 20:19 (31 days ago)

Hi,

i've installed selfoss 2.18 on Debian 11 according to an installation how-to from the wiki [0].
After adding a feed (manually or built-in) no content gets loaded, the page says 'no entries found'. After activating debug logging the default.log file shows the following error:


[2022-04-25 18:31:11] selfoss.ERROR: error loading feed content for Golem {"exception":"[object] (Exception(code: 0): XML or PCRE extensions not loaded! at /var/www/html/selfoss/spouts/rss/feed.php:160)
[stacktrace]
ss\\feed->load()/selfoss/spouts/rss/golem.php(112): spouts\
ss\\golem->load()selfoss/helpers/ContentLoader.php(99): spouts\
#2 /var/www/html/selfoss/helpers/ContentLoader.php(53): helpers\\ContentLoader->fetch()
#3 /var/www/html/selfoss/controllers/Sources.php(290): helpers\\ContentLoader->updateSingle()
#4 /var/www/html/selfoss/vendor/bcosca/fatfree-core/base.php(1806): controllers\\Sources->update()
#5 /var/www/html/selfoss/vendor/bcosca/fatfree-core/base.php(1627): Base->call()
#6 /var/www/html/selfoss/index.php(80): Base->run()
#7 {main}
"}

According to the PHP documentation the PCRE module is part of the core, running php -m correctly shows the pcre module as compiled and loaded. A phpinfo file i set up shows the pcre module is present and loaded as well.

php -v

PHP 7.4.28 (cli) (built: Feb 17 2022 16:17:19) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with Zend OPcache v7.4.28, Copyright (c), by Zend Technologies

Any ideas on where i went wrong or what else i can check for?

[0] https://github.com/fossar/selfoss/wiki/Install-on-Raspbian-GNU-Linux-10-%28buster%29-with-lighttpd-and-mariadb


Complete thread:

 RSS Feed of thread

powered by my little forum